My 3ds Max is very slow, it is hard to navigate in the viewport!



Note: please always contact us about this issue, even if you have already managed to find a solution or workaround yourself. This will help other users, and will also help us fix similar issues in the future. 



Symptoms


This article applies if the following symptoms can be observed:

  • Viewport becoming very slow
  • It is hard or impossible to work in the viewport due to freezes

Additional possibilities:
  • Other parts of the 3ds Max UI are slow as well (material editor, menus, moving objects,...)
  • It happens in a newer version of Corona, but not in an older one (e.g. happens in 1.4, but not in 1.3)
  • It only happens in scenes where textures are in network locations (paths starting with \\name\... )
  • It happens with Corona Bitmap and 3ds Max Bitmap nodes, or only with the Corona Bitmap or 3ds Max Bitmap
  • Disabling/enabling maps in viewport does not change anything



Possible solutions:


 1. If after inspecting the resource monitor, the following can be established:
  • HDD usage is excessive
  • MsMpEng.exe (Windows Defender process) is running and causing the HDD to run slowly


Currently the solution is to add 3ds Max to Windows Defender exceptions, or disable Windows Defender completely.

Note: this issue might be also appearing when using other antivirus/firewall software than Windows Defender. In such case it is also advised to disable that application, or add 3ds Max to its exceptions list.



2. If disabling Windows Defender or other AV software does not help:

Check if converting all bitmaps in your scene to Corona Bitmap or 3ds Max Bitmap helps. If that's the case, please contact us about this. 



3. If the issues is not related to AV software or Corona/Max Bitmaps:

See this forum thread for a possible solution: https://forums.chaosgroup.com/forum/v-ray-for-3ds-max-forums/v-ray-for-3ds-max-problems/967548-v-ray-3-6-vfb-hangs?p=975884#post975884



4. If you are using geometry plugins such as FloorGenerator and/or texture plugins such as MultiTexture:

Check if disabling or removing objects and texture maps generated by those plugins resolves the problem. If this helps, consider converting generated objects (such as FloorGenerator floors) to Editable Mesh or Editable Poly and using Corona's built in CoronaMultiMap map in place of MultiTexture as it provides very similar functionality.