Hardware Requirements


For hardware and software requirements of Corona Renderer visit our official website: Getting Started




Standard and legacy versions


Up to Corona Renderer 1.7 hotfix 2, the universal installer has contained two versions of the Corona Renderer plugin – standard and legacy:

  • The standard version uses SSE4.1 instructions set to achieve maximum speed on modern Intel (i3/i5/i7 or newer Core 2) and AMD (Bulldozer architecture and newer) CPUs.

  • The legacy version should run on all CPUs from the last decade, but it is about 20% slower.


From Corona Renderer 2 onward, the legacy version will no longer be offered, and you will need a CPU that supports the SSE4.1 instruction set (that is, any processor from within the last 10 years). Here is a list of compatible CPUs


From Corona Renderer 3 onward, the Licensing Server and the DR Server will no longer support CPUs without the SSE4.1 instruction set and are now 64-bit only applications (they will not run on 32-bit versions of Windows).




Optional: Fast Preview Denoiser (Nvidia OptiX)


To use our Fast Preview Denoiser (Nvidia OptiX), you need an Nvidia GPU with Kepler or newer architecture and the newest GPU driver. Not all mobile GPUs are supported.

Note: this denoiser type is optional, and Corona Renderer will work fine even if it's not installed (for example if you are using an AMD or integrated GPU). We also offer a High Quality denoiser, which utilizes purely the CPU, and this denoiser can be used on any computer which can run Corona Renderer. 

See: How to use denoising?